After almost a week of downloading it via torrent, I have finally finished downloading the latest and the greatest of Free DVD version of Mandriva Linux. The md5sum checks out so I off to burning it goes so I can begin installation on the following day (I still need to go to work!)

Machine: Fujitsu Siemens Amilo ProV7010, 3.0Ghz, 1.5GB. Code name: Lala (the laptop)

Installation _the first time_ was pretty painless. Mandriva was up and running within 30 minutes. I performed an install and reused my partitions, retaining only the contents of /home and /storage.

First problem: Wireless was not working.

No problemo as this already happened with 2007. Lugged my laptop in the shared living room and used a wired connection to connect to the Internet. Configured a DHCP connection using the network utility in the system tray. Did a quick visit to rpmfind.net to look for the prism54-firmware package. Download, open terminal, su to root , install firmware package. Disconnect wired connection.

Using the network utility in the system tray, I tried to configure a Wireless connection. I opted to use the Intersil Javelin driver instead ndiswrapper. Configuration was reported to be successful. Weirdly, there is no wireless connection.

Tried the network configuration utility again to redo the wireless connection. This time I opted to use the ndiswrapper route. Everything looks good. Along the way the wireless connection got connected and the system tray got the ! Yipee! At the last screen I was asked if I want to start the connection during startup. Oh yes! Press OK.

Network system tray popped with a red error message. No connection. Eyebrows began to meet. What the? Right-click on the system tray->Manage Wireless Connections, select wireless router that is a few feet of me. Laptop does something. After a few minutes still no connection. ifconfig, iwconfig , man. Nothing.

Open network system tray again. Do the wireless configuration again. Before the last screen I noticed that the system tray network utility reports a connection again. Do you want to start the connection at startup? Thanks but no thanks buddy. I selected no and dismissed the wizard.

Ok, so I now have a wireless connection. I lugged my laptop back to my room at the other end of the apartment. So far so good. Started up Mozilla Thunderbird to get my mail. Nothing happens. My accounts were recognized but my mails are not in the mailboxes!

Reboot to Windows to check. Goodie, my mails are still all there. I checked the Thunderbird version and they are the same: 2.0.0.6.

Rebooted to Mandriva, and then I got my second shock. During the network boot scripts, an error was shown that the wlan0 device is not available. Upon boot-up I did the trick with the network utility and all is fine again.

Time to sleep. I need to figure out what went wrong with the initialization part of the wireless boot up.

ciao!